Topic

Help! Phased out on an Icecrown Quest?

Rocklock @ Kirin Tor
Rocklock

Blood Elf Warlock
Edited on 2019-07-31 16:43:05
On the quest Army of the Damned in Icecrown, I tried to exit the phase, and instead if regularly unmounted me, making me stuck in the past-phase that it was in. I'm now stuck in the Icecrown Quest, and had abandoned it in the hopes that I could try to re-grab the quest and hopefully it would just put me in the Arthas mechanic and fix the problem.
EDIT: I fixed it by drowning and getting rez sickness.

Boujii @ Kirin Tor
Boujii

Human Paladin
That was easy.. Is there anything else I can do for you? lol :p

In order to post you must to be logged in

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Click here to view the Forums Code of Conduct.