Topic

I can't get Instant 70 to work

Kyreol @ Kirin Tor
Kyreol

Night Elf Hunter
It shows me the two available characters I have, but whenever I click "Next Step" the button just turns half grey, and nothing happens. I can never progress to the next screen.

I have tried Chrome. I have turned off Adblock. I have tried Brave. I have put shields down. Still no luck. The only button which works is the "Cancel" button. I have tried right clicking, and that just wants to look up the word "Next". What am i doing wrong? I am on a Mac.

Plainfeather @ Kirin Tor
Plainfeather
Moderator
Hello!

Click first on "Free Instant", then click on the Next Step button.

Relyna @ Kirin Tor
Relyna
Blood Elf Mage
I'm having a problem where the drop down isn't showing any characters. What can i do?

In order to post you must to be logged in

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Click here to view the Forums Code of Conduct.